1 snippet pkgver "pkgver() function" b
3 cd ${1:$pkgname-$pkgver}
5 git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
6 printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
11 snippet prep "prepare() function" b
13 cd ${1:$pkgname-$pkgver}
18 snippet build "build() function" b
20 cd ${1:$pkgname-$pkgver}
23 --libexecdir=/usr/bin \
26 --localstatedir=/var \
33 snippet build32 "Standard lib32 make" b
37 export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
39 cd ${1:$pkgname-$pkgver}
44 --localstatedir=/var \
50 snippet pack "package() function" b
52 cd ${1:$pkgname-$pkgver}
53 make DESTDIR="$pkgdir" install
58 # vim:set ft=snippets: